This page lists all current and previous versions of Ed-Fi Technology, each with a support status and licensing information for the specific version. Currently supported products have links to documentation and downloads. The support status is listed for each product. Key:

  • (tick) Active: the product is in active development and/or will have new patch releases as needed. Patch releases are not guaranteed, however: this depends on the severity of issues found.
  • (warning) Early access: currently accepting feedback at a pre-release stage
  • (warning) Ends soon: the product will soon transition to Unsupported status.
  • (error) Unsupported: while there may be exceptional circumstances, the Ed-Fi Alliance has stopped all development and releases on this line of work.

When a support request comes in for an unsupported product, the support team can help triage a problem by finding existing workarounds or clarifying documentation. If there is no fix available for the issue, the team will encourage the requesting agency to upgrade to the most recent applicable product.

The Alliance tries to adhere to Semantic Versioning 2.0.0. In short, for version number X.Y.Z (where X.Y implies "most recent Z"):

  • The first digit X signifies a major release that may have changes that are not backward compatible.
    • Caveat: We have also used the major version number when the API is technically backward compatible, but the implementation technology is not (for example, switching from .NET Core 2 to .NET 6, which requires a change in the components required to run the software).
  • The second digit Y is for a minor release, which introduces new features without breaking old ones. 
    • Caveat: a minor release could contain some pre-release / experimental features. There will be a clear signal when this happens. When marked as experimental, the feature might be absent or radically changed in the next minor release.
  • The third digit Z applies to a patch release with backward compatible bug fixes or clarifications.

Related documents:

  • The Ed-Fi Technology Roadmap communicates the planned schedule of releases and is updated quarterly. All dates are estimates and subject to change.
  • The Ed-Fi Technical Suite Version Matrix provides a reference to the Technical Suites and their compatibility with specific product and service versions.

Products:

  


Ed-Fi Data Standard


SuiteProduct & VersionRelease DateStatusLicense
Suite 3Data Standard v5.0

(tick) LatestApache License, Version 2.0
Data Standard v5.0-pre2

 

(error) Use v5.0.0
Data Standard v5.0-pre1

 

(error) Use v5.0.0
Data Standard v4.0

(tick) Active
Data Standard v4.0.0-a

 

(error) Use v4.0.0

Data Standard v3.3.1-b

(tick) Implicitly, this is v3.3.1 "final" despite the "b" in the name

(tick) Active
Data Standard v3.3.0-a

 

(tick) Active
Data Standard v3.2

(error) Unsupported
Data Standard v3.1

(error) Unsupported
Data Standard v3.0

(error) Unsupported
Suite 2Data Standard v2.2

(error) Unsupported


Data Standard v2.1

Data Standard v2.0.1

Suite 1

Data Standard v1.2

(error) Unsupported


Data Standard v1.1.1

Data Standard  v1.1

Data Standard  v1.0





  


Ed-Fi ODS / API Platform


SuiteProduct & VersionRelease DateStatusLicense

 

Suite 3










Ed-Fi ODS / API for Suite 3 v7.1

Ed-Fi ODS / API for Suite 3 v7.0

 

 

(tick) Latest

(error) Use 7.1

Apache License, Version 2.0

Ed-Fi ODS / API for Suite 3 v6.1

Ed-Fi ODS / API for Suite 3 v6.0

 

(tick) Active through 2025-2026 school year

(error) Use 6.1

Ed-Fi ODS / API for Suite 3 v5.3

 

(tick) Active through 2024-2025 school year

Ed-Fi ODS / API for Suite 3 v5.2

Ed-Fi ODS / API for Suite 3 v5.1

Ed-Fi ODS / API for Suite 3 v5.0.0v5.0.1

 

 

,

(error) Unsupported

Ed-Fi ODS / API v3.4v3.4.1

 ,

Ed-Fi License



Ed-Fi ODS / API v3.3

(error) Unsupported



Ed-Fi ODS / API v3.2

 

Ed-Fi ODS / API v3.1.0, v3.1.0.1, v3.1.1

 

 

 

Ed-Fi ODS / API v3.0

 

Suite 2ODS / API v2.6

(error) Unsupported










ODS / API v2.5

ODS / API v2.4

ODS / API v2.3.1, v2.3.1.1

,

ODS / API v2.2.0.1

ODS / API v2.1.1

ODS / API v2.0

ODS / API v2.0 - Technical Preview, Beta

,







 

Ed-Fi Tools


Admin API

Admin App

SuiteProduct & VersionRelease DateStatusLicense
Suite 3





Ed-Fi ODS/API Admin App v3.1

Supports ODS/API 5.3 to 6.1

 

(tick) LatestApache License, Version 2.0

Ed-Fi ODS / API Admin App v2.3
(for ODS/API 3.4 - 5.3)

Ed-Fi ODS / API Admin App v2.2.1
(for ODS/API 3.4 - 5.2)

Ed-Fi ODS / API Admin App v2.2
(for ODS/API 3.4 - 5.2)

Ed-Fi ODS / API Admin App v2.1
(for ODS/API 3.4 - 5.1)

Ed-Fi ODS / API Admin App v2.0.1
(for ODS/API 3.4 - 5.0)




  

 

 

(error) Unsupported

Ed-Fi ODS / API Admin App v1.8.1
(for ODS/API 3.4)

Ed-Fi ODS / API Admin App v1.7
(for ODS/API 3.3)

Ed-Fi ODS / API Admin App v1.6
(for ODS/API 3.2)

Ed-Fi ODS / API Admin App v1.5
(for ODS/API 3.1.1)


 

 

 

 

(error) UnsupportedEd-Fi License
Suite 2

Ed-Fi ODS / API Admin App v1.5.1
(for ODS/API 2.5 or 2.6)

Unsupported

API Publisher

SuiteProduct & VersionRelease DateStatusLicense



Suite 3


API Publisher v1.0 for ODS / API 5.3 and 6.1

 

(tick) LatestApache License, Version 2.0



Data Import

SuiteProduct & VersionRelease DateStatusLicense
Suite 3

Data Import v2.2


(tick) ActiveApache License, Version 2.0

MetaEd IDE

SuiteProduct & VersionRelease DateStatusLicense
Suite 3

MetaEd v4.3

MetaEd v4.2

MetaEd v4.1

MetaEd v4.0

 

 

  

(tick) ActiveEd-Fi License
Suite 2 & 3

MetaEd v3.2

MetaEd v3.1

MetaEd v3.0

MetaEd v2.5

MetaEd v2.4

MetaEd v2.3

MetaEd v2.2

MetaEd  v2.1

MetaEd v2.0

 

 

 

(error) Unsupported
Suite 2MetaEd v1.4.1

MetaEd v1.3.1

MetaEd v1.2.1

MetaEd v1.1.5

MetaEd v1.0






Install & Upgrade



 

Docker Deployment Scripts

For general product information, see Docker Deployment 2.x. The links below are to the GitHub releases.

SuiteProduct & VersionRelease DateStatusLicense
Suite 3

Ed-Fi Docker Deployment v2.3.1
Supports ODS/API 6.1

 

(tick) SupportedApache License, Version 2.0

Ed-Fi Docker Deployment v2.3.0

 

(error) Unsupported
Ed-Fi Docker Deployment v2.2.0

 

Active

Ed-Fi Docker Deployment v2.1.5
Supports ODS/API 5.3-patch4

 

(tick) Supported

Ed-Fi Docker Deployment v2.1.2

 


Ed-Fi Docker Deployment v2.1.0

 

(error) Unsupported
Ed-Fi Docker Deployment v2.0.1

 

(tick) Active
Ed-Fi Docker Deployment v2.0

 

Active

Ed-Fi Docker Deployment v1.1.1
Supports ODS/API v5.1-patch2

 

(tick) Supported
Ed-Fi Docker Deployment v1.1.0

Active
Ed-Fi Docker Deployment v1.0.0

Active


  • No labels